CONF_FILE setting is no longer supported


(Kishore) #1

I am upgrading the Eleasticsearch version from 1.5.0 to 2.1.1
While installing plugin i am getting below message

'CONF_FILE setting is no longer supported. elasticsearch.yml must be placed in the config directory and cannot be renamed.'

Kindly help me in solving this issue.


(David Pilato) #2

What exactly did you do?

I think you did not update the plugin script.


(Kishore) #3

Yes, i didn't update the plugin script, Please help me in update the plugin script.


(David Pilato) #4

So update the plugin script.

Again, I don't know what you are doing.

I guess you did not read https://www.elastic.co/guide/en/elasticsearch/reference/current/breaking-changes-2.0.html


(Kishore) #5

I am trying to install plugins.


(David Pilato) #6

May be you don't understand when I'm saying the following?

update the plugin script

and

What exactly did you do?


(Kishore) #7

Thank you for your response, I am in hurry to complete the task, so i got stuck.

Still i am in confusion .

Kindly guide me.


(David Pilato) #8

Sorry. I can't help.


(Ekovacs) #9

Hi!
Same thing happened to me.

For me the solution was to go to
/etc/sysconfig
folder and comment out the line which had CONF_FILE in it.

I also shared this solution on the github issue:


Error installing graph plugin
(system) #10