Error during Marvel 2.0 UI plugin installation

monitoring

(Pieter Agenbag) #1

Hi - I had just installed a fresh Elasticsearch 2.0 and Kibana 4.3 snapshot for evaluation and thought I'd add Marvel on as well.. but I get the following when attempting to install the UI plugin

root@sin-cpt-sl-elk2-dev:~/kibana-4.3.0-snapshot-linux-x64# bin/kibana plugin --install elasticsearch/marvel/latest
Installing marvel
Attempting to extract from https://download.elastic.co/elasticsearch/marvel/marvel-latest.tar.gz
Downloading 1498411 bytes....................
Extraction complete
Optimizing and caching browser bundles...
Plugin installation was unsuccessful due to error "Optimizations failure.

    ERROR in ./installedPlugins/.plugin.installing/public/views/overview/index.js
    Module not found: Error: Cannot resolve module 'angular-bindonce' in /home/sintrex/kibana-4.3.0-snapshot-linux-x64/installedPlugins/.plugin.installing/public/views/overview
     @ ./installedPlugins/.plugin.installing/public/views/overview/index.js 11:2-29

Any ideas ?

I tried npm install -g angular-bindonce , but it made no difference.

Update: I downloaded Kibana 4.2.1 and managed to install the Marvel plugin without problems , but when I then tried to install the TimeLion plugin (which I had allready installed in 4.3) , I got a similar 'Cannot resolve module' error.

So - Either Marvel and TimeLion does not play nice together ... or its Kibanas handling of multiple user installed plugins that has issues


(Elain) #3

I have the same problem,


(Tanguy) #4

At this time Marvel plugin is compatible with Kibana 4.2.1.

Snapshot builds can break compatibility with already released plugins like Marvel 2.0 so there's no guarantee both works together.

-- Tanguy


(system) #5