How can I change the timezone on Kibana?

I've noticed that my Kibana has a 3hours difference with my actual time. I've been looking into similar cases but so far changing the timezone in the Advanced Settings hasn't worked yet. What other ways could I try to achieve this?

I've extracted the Kibana current time by this query by the way:

| formatdate "MM/DD/YYYY HH:mm:ss"
| markdown "current time: " {context}
| render

Is this in Canvas?

The main issue here is that all date fields in Elasticsearch are stored in UTC and Kibana will convert the UTC time to the timezone configured in Advanced settings, per default it will use the Browser timezone, which will inherit the timezone from the OS.

But this conversion does not happen in every place in Kibana and if I'm not wrong, Canvas is one of the places where the data will always appear in UTC, no matter what you do.

There was an old issue about this, but was closed without a solution.

1 Like

Thank you for the fast reply. It is indeed in the canvas. While in charts I did a workaround with the "interval" like this:

CAST(create_time as DATETIME) - INTERVAL 3 Hours

I was wondering if there is a way to do something similar to the timefilter. As I don't know if there is a way to set into SQL there the idea just went away.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.