Installing new version of custom plugin Kibana 7.10

I'm writing a custom plugin in Kiabana 7.10. I've got it running on my local copy of Kibana. I then do a yarn build command and copy the zip file to our dev server. I then install the plugin using the kibana/bin/kibana-plugin install command. This works great. I then make a change to the plugin on my local copy of Kibana, build the plugin, copy it to the dev server and run kibana/bin/kibana-plugin remove on my plugin. I then restart Kibana. Once it's back up, I run the kibana/bin/kibana-plugin install command to install my updated plugin and restart Kibana. In previous version of Kibana this would load my new plugin. However, after doing these steps on Kiabana 7.10, my changes are not showing up on the dev server. Is there some other thing I need to do to make sure an updated plugin is loaded and not the old one?

I'd try clearing rm -rf kibana/optimize/bundles folder so it will force it to optimize again when you start back up Kibana and see what happens.

I've ran that command in the past as well. However, there is no optimize directory in Kibana 7.10.0. Here's the directory structure:

-rw-rw-r--.   1 express express 3.9K Nov  9 17:16 README.txt
-rw-rw-r--.   1 express express  740 Nov  9 17:16 package.json
-rw-rw-r--.   1 express express 1.3M Nov  9 17:16 NOTICE.txt
-rw-rw-r--.   1 express express  14K Nov  9 17:16 LICENSE.txt
drwxrwxr-x.   2 express express   64 Jan  7 17:34 bin
drwxrwxr-x.   6 express express  108 Jan  7 17:34 node
drwxrwxr-x.  11 express express  160 Jan  7 17:34 src
drwxrwxr-x.   4 express express  116 Jan  7 17:34 x-pack
drwxrwxr-x. 995 express express  28K Jan  7 17:34 node_modules
drwxrwxr-x.   2 express express   44 Jan  7 17:44 config
drwxrwxr-x.   2 express express   18 Jan  7 17:44 data
drwxrwxr-x.   5 express express   72 Jan  8 11:08 plugins

Looks like 7.10 doesn't have that anymore so that isn't an option anymore. Maybe someone else will know how to fix this, sorry.

Anyone else have any suggestions on this? I'm still not able to remove a plugin and then reinstall that plugin after making changes. Kibana still loads the old plugin.

Have you attempted to just rename the folder and plugin slightly? Then just rename back if required.

Definitely not the correct way, just an idea to see if it will force it to load.