Issue setting up minimal security for elasticsearch

I have been following the instruction for setting up the minimal security features on ELK stack and keep running into the same problem.

when I try to run the command

./kibana-keystore.bat add elasticsearch.password

I get the message:

Enter value for elasticsearch.password: **********

TypeError: output.cursorTo is not a function
    at Socket.<anonymous> (C:\Users\thatG\Downloads\ELK\kibana-7.13.4-windows-x86_64\src\cli_keystore\utils\prompt.js:76:20)
    at Socket.emit (events.js:387:35)
    at addChunk (internal/streams/readable.js:290:12)
    at readableAddChunk (internal/streams/readable.js:265:9)
    at Socket.Readable.push (internal/streams/readable.js:204:10)
    at Pipe.onStreamRead (internal/stream_base_commons.js:188:23)

has anyone else run into this issue/know a fix?


I usually use Built-in users | Elasticsearch Guide [7.14] | Elastic
in elasticsearch to set up passwords for built in users.

Do you get the same error if you try it in es directory?

cc @Marius_Dragomir


Kibana does not properly start at the moment so I cannot try the built in users.
If I comment out the security lines from both YAML files it begins to work properly w/o security.
I will try that command in the ES path. I had not yet because the setup guide on the website told me:

I tried running them directly from the bin folder and nothing failed. Are you using command prompt or Powershell?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.