Kibana 5.2 +x-pack error when generating reports


Hi Brandon,

Firstly, thanks for your explanation.

I have exactly the same problme. I'm using the Filebeat + Logstash + Elasticsearch + Kibana (all of them are in the last version 5.2.1) on one VM - 6 processors & 8 Go.

The OS is RHEL7.1 and I installed them by RPM (execpt for plug-in X-Pack of course). I started them by systemctl then the same problem occurred :

> Error: Kibana took too long to load - Timeout exceeded (30000)

I followed your suggestions to activate kibana log for more information and i found :

{"type":"log","@timestamp":"2017-02-22T11:07:58Z","tags":["reporting","debug"],"pid":1469,"message":"fetching screenshot of'2017-02-16T23:10:16.092Z',mode:absolute,to:'2017-02-17T18:35:18.291Z'))&_a=(filters:!(),options:(darkTheme:!f),query:(query_string:(analyze_wildcard:!t,query:'*')),title:'Dashboard%20-%20Apache%20-%20EDF%20-%20test')"}
 {"type":"log","@timestamp":"2017-02-22T11:08:31Z","tags":["reporting","debug"],"pid":1469,"message":"Screenshot failed Kibana took too long to load - Timeout exceeded (30000)"}
{"type":"log","@timestamp":"2017-02-22T11:08:32Z","tags":["reporting","worker","debug"],"pid":1469,"message":"printable_pdf: Worker error: (izguw1re014tc7f584cs743p)"}

I tried to access the URL in the "fetching" line by browser in the VM, it had the same error : Timeout exceeded (30000)

I also ajusted the timeout to 60000 in kibana.yml but it seems nothing changed (still timeout after 30 seconds) : "" "new"
logging.dest: /var/log/kibana/kibana.log [ 'reporting' ]
xpack.reporting.kibanaServer.protocol: http
xpack.reporting.queue.timeout: 60000

BTW, I'm in DEV evironement so there is no proxy in front and I have only one node.

Do you have any idea ?