Kibana- TIme Range filter in Dashboard does not work


(Nerin) #1

Hi Peeps,
New to ELK.

I have my Dashboards displaying a count of occurrences from the time i started logging.
How do i make the Time Range Filter options in Kibana to work.
Attached screenshot of the feature.
image

Any help will be appreciated


(Larry Gregory) #2

Hi @Nerin

What about the time range filter isn't working? Can you share your full dashboard, and explain what you're expecting to see versus what you actually see?


(Nerin) #3

Hi @Larry_Gregory,

Thanks.

So when i create a filter like so, this works. Example This month
image

But if i click the Quick Option ' This month' , the data still shows the fill set of count from the beginning of logging.
image

When i click on the filer i created- this works - dashboad:

When i click on the Quick Option ' This month' from the filer Range - Doesn't works - dashboad:

Thank you for the help :slight_smile: :slight_smile:


(Larry Gregory) #4

Thanks for the added detail and screenshots. If you choose "month to date" instead of "month" in the time range filter, do you see a similar result to using your custom "This Month" filter?

The time range "This month" filter will include results up to the end of the current month, whereas "Month to date" will include documents up to the current time.


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.