Marvel.agent.exporter.http could not connect to any configurd elasticsearch instances

monitoring

(Netanel Malka) #1

I have elasticsearch prod cluster of two nodes(es-prod).
I created another cluster for monitoring those elastic nodes(es-mon).
Thus, I configured the marvel agent for monitoring cluster as explained here:
monitoring-cluster

But I still got this ERROR message on the es-prod nodes.
In kibana, marvel calims that there is no data.
Also, there is no .marvel indices on the es-mon elastic.
The main error message:
marvel.agent.exporter.http could not connect to any configurd elasticsearch instances[<instance_name>]
I be able to connect from the es-prod to the es-mon elastic.
But, somehow marvel failed to connect...
version details:
marvel- 2.4.1
elasticsearch - 2.4.1
kibana - 4.6.2
Thanks..


(Joe Fleming) #2

Are you sure that whatever hostname and port you're using on the es-prod nodes can actually be accessed from those machines? If you've got a firewall or something in between es-prod and es-mon, perhaps it's blocking that communication.

EDIT: Also, are you using Security? If so, have you added the auth defaults to your config file?


(Netanel Malka) #3

Yes. I succeeded to connect from es-mon to es-prod and from es-prod to es-mon.
Also, I don't use Security yet...
I tried to remove marvel and set up again, but it doesn't help.
Thanks a lot.


(Bohyun Kim) #4

Hi @Netanel_Malka

based on the error, it seems like the monitoring cluster, es-mon, is not reachable. Could you make sure that your es-mon cluster is running?

Also, could you share your config settings(elasticsearch.yml) for both your es-mon and es-prod clusters?

Thanks,
Bohyun


(Netanel Malka) #5

I don't know what happened but today I found that .marvel indices created in the es-mon,
In the kibana.yml file, I set the elasticsearch_url: es-prod instead of es-mon.
Now it works.
Thanks a lot for your quick responses :smiley:
Netanel


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.