Old kibana saved objects still showing after changing “kibana.index” config setting


(Anthony Leonard) #1

Steps to recreate:

  • default install and start of kibana (5.2.0)
  • save a saved search, visualization or dashboard
  • shutdown, change kibana.index in config/kibana.yml:
    • from ".kibana" (default)
    • to: ".kibananew"
  • restart kibana and browse to management > saved objects

Expected: No saved searches, visualisations or dashboards to be present, because it should be looking for them in ".kibananew" which is empty?

Actual: They're still there.

Any help much appreciated! :slight_smile:

Also asked on SO but no response! https://stackoverflow.com/questions/48663743/old-kibana-saved-objects-still-showing-after-changing-kibana-index-config-sett


(Marius Dragomir) #2

I just tried this on my local 6.2.0 Kibana and it worked properly.
Was the .kibananew index created properly on your side? or was Kibana still stuck on .kibana and this is why you still saw the objects?


(Anthony Leonard) #3

So on second attempt this worked for me - i.e. I got the expected outcome above.

Either browser caching was an issue or I messed up!

Thanks for your help :slight_smile:


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.