Plugin not working on Elastic version 6.3.0


I am having issues with a customised plugin when installed on the latest version of Kibana - 6.4.

I have initially customised the pivot table plugin for the kibana version 6.2.3/6.2.4 (found through this link and it has been working correctly as shown below.


Now, I have installed the latest version of Elastic Stack, and i have modified the «package.json» file (path: "...\kibana-6.2.4-windows-x86_64\plugins\pivot_table\package.json" of the plugin to that version of Kibana installed.
Now, i cant even use the «»Discover,«Visualize» and the «Dashboard» tabson Kibana or even try to create a visualisation after having cleared the cache in kibana by deleting the «bundles» folder (path : "...\kibana-6.2.4-windows-x86_64\optimize\bundles").

And lastly, I found this article on the elasticsearch website:

Site plugins — plugins containing HTML, CSS and Javascript — are no longer supported.

Note: This plugin works primarily on javascript files even though it is installed in the kibana directory and that warning is for elasticsearch plugins.

link to this article:

So my question, is there a way to correct this issue, or the latest version support of kibana do not support these types of plugins?

Thanks in advance,

First, I would recommend actually creating a new build of the plugin. Hacking the package.json after it's been install is usually not sufficient.

This plugin is not an Elasticsearch Site Plugin, it's a Kibana plugin - so no issues there.

Hello tylersmalley,

As suggested by you, I did create a new build of the plugin, but the issue is still not resolved. What corrections should be additionally made to the plugin for it to be compatible for a new version stack?


Ganessen, not sure if this is relevant to your issue or not, but there was a breaking change in the way plugins receive data from the API. It is described at the bottom of the release blog:

Another possibility is that in 6.3 we removed Angular from one of the classes you used. If that is the case, you will need to change the imports. The most likely culprit for your case seems to be Schemas: see

Hello Raya,

I am taking into account the several points you mentioned and will get back to you once I tried to apply these corrections.


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.