TIlemap zoomin come's short


(Yaacov Kitainik) #1

Having trouble with Tilemap.

Using the WMS compliant maps on http://ows-tile.terrestris.de/osm-basemap/service?
i got that the map is going zoomin till certain level and after that, the + button is going gray and i cant zoom anymore.

I've recently installed a linux env with KIBI 4.4.2-1 and elastic 4.5.4
in previous poc windows installation ( kibi 4.4.2 ) was working fine.

BR,
Yaacov


(Tim Sullivan) #2

I suspect that your map visualization is possibly using the default Elastic Tile Service, instead of Terrestris.de. Does the attribution in the lower right-hand-side say Elastic Tile Service?

To use a WMS-Compliant map in Kibana 4.5.3+, you need to explicitly enable the WMS server option for each visualization under the visualization's "Options" tab.

See: https://github.com/elastic/kibana/issues/7717#issuecomment-238044911

If you use a WMS-compliant service, be sure to use a correct attribution. That will show up in the visualization and help you make sure you are using the service you expect.


(Yaacov Kitainik) #3

Tnx Tim,

After upgrading to 4.5.3 and enabling the WMS complaint is working fine!.

How can i change the default map to be Terrestris.de. instead?
i tried changing on setting > Advanced > visualization:tileMap:WMSdefaults without success

BR,
Yaacov


(Tim Sullivan) #4

The Settings > Advanced > visualization:tileMap:WMSdefaults setting just sets up defaults to use for WMS map visualizations. You still need to go to the Options for your TileMap visualization and check "WMS compliant map server" and either use the defaults or customize them in the corresponding form fields.

If it's still not working, can you share the config JSON you are using for the visualization:tileMap:WMSdefaults option?


(system) #5