Time Range in Dashboards not working

Hi,

I'm using Metricbeat to save info into an index in ElasticSearch v6.7. The name of the index is classifier.

Then, I built a Visualization in Kibana using that index to show the number of requests for a service.

Then, I added that visualization into a Dashboard.

The problem is that if I change the Time Range in the top-right corner the number in the visualization does not change. It always shows the total number of requests in the index.

In the image, the number of requests for the last 15 minutes should be zero.

What am I doing wrong?

Do you encounter the same problem in Discover? My guess is that the time field you've configured for your index pattern (which the time picker will use) is not the same time field you expect it to filter on. You can see which field is configured as your time field on the index pattern management screen. There will be a clock icon next to the time field:

1 Like

Thanks Matt, I guess that is the problem, because it doesn't appear the clock. The field date is the only field of type date. How should I configure the field to use it with time picker?

Note: Yesterday I updated Kibana to v7.1.1.

I solved removing and creating a new index-pattern and setting the date field as Time Field.

Thank you for the tip!

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.