Trying to configure Marvel on monitored node gets "Illegal User Settings"

monitoring

(Don LeClair) #1

I am attempting to follow the documentation to get marvel monitoring set up for my 2.4 cluster. The doc (https://www.elastic.co/guide/en/shield/current/marvel.html) says to input this in the YAML config:

marvel.agent.exporters:
  id1:
    type: http
    host: ["http://myhost"]
    auth:
      username: agent-user
      password: password

I put in the actual host name, and the agent-user and password that I set up on the separate monitoring node. When I select Update I get the message "Illegal User Setting".

Any suggestions on how to get past this?


(Chris Earle) #2

Hi Don,

When I select Update I get the message "Illegal User Setting".

When you selected update where? On Elastic Cloud?


(Don LeClair) #3

Yes. I am on Elastic Cloud.

And now that I have my Kibana straightened out, It appears that you don't have to do this step in the documentation, as I seem to be able to see information in Marvel.


(Don LeClair) #4

So we can close this one out.


(Chris Earle) #5

Hi Don,

Yeah, Elastic Cloud automatically configures a lot of things that normal Elasticsearch / Kibana users must do themselves.

Glad that it worked out! I hope that you can upgrade to ES 5.x soon too.

Thanks,
Chris


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.