Unable to execute Kibana.bat on Windows 10

After downloading and unzipping the zipped Kibana (6.6.0) file from elastic's website, I'm unable to execute the Kibana.bat file via command line. It produces these errors:

./kibana.bat: line 1: @echo: command not found
./kibana.bat: line 3: SETLOCAL: command not found
./kibana.bat: line 6: syntax error near unexpected token `('
./kibana.bat: line 6: `for %%I in ("%SCRIPT_DIR%..") do set DIR=%%~dpfI'

I tried searching the web, but was unsuccessful in finding a hint. Has anyone experienced this before?

Are you using Command Prompt or PowerShell?
Are you executing it from the root bin\kibana.bat?


I ran ./bin/kibana.bat via the Command Prompt which produced the errors that I've noted in my earlier post.

I tried via PowerShell (Administrative) and it now works. This was the same for Elasticsearch.

P.S. @tylersmalley Thank you for your response.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.