Remote Server is not ready to accept connections

Hello,

I am trying to set up fleet-managed agents on an air-gapped environment. The elastic package registry is up and running. Fleet server is also running and healthy. If I try to enroll an agent on a machine that is connected to my host (where the fleet server is running) I don't get past the point "Remote Server is not ready to accept connections". I tried different ports and settings in the Elasticsearch.yml but cannot get it to work.

Setup:
Elasticsearch with security enabled (basically downloaded and ran Elasticsearch.bat)
set up fleet server (quick start) according to instructions

I am not sure which information I should provide so please let me know, thanks!

Hello @ttss15, welcome to this forum!

Which guide have you followed? There is a dedicated guide for air gapped environments Air-gapped environments | Fleet and Elastic Agent Guide [8.2] | Elastic

Given the error, as a general guidance, I would suggest to double check if fleet server is really running and accepting connections, if yes double check that when you enroll the agent you are pointing to the right URL.
Please provide more information about what you tried and your infrastructure (es commands you run or guide you followed and error logs). Please also consider I'm not very familiar with Elastic Agent in air-gapped environment, so I'm referring mainly to publicly available documentation.

(A way to speed up this may be to contact our support, if you have a support contract in place)